This project is read-only.

PcapDotNet.Core.dll files not found

Dec 6, 2011 at 8:24 PM


I'm trying to build a setup in order to run on a clean installation of windows 7, but i am some problems with needed files of PcapDotNet.Core.dll. I've installed .NET framework 4 full, Visual C++ 2010 Redistributable and when i run the application that use pcapdotnet i have the error "some files are missing or one of it's dependency of PcapDotNet.Core.dll". I've tried on 2 computers with Clean installation of Windows 7 and on both computers i have the same problem. On one computer i've installed prereq of Visual Studio (after VC++ runtimes) the app works.


Any ideas why the redistributable is not enough? The link is (

Dec 7, 2011 at 12:04 PM

1. Install Winpcap, you might forget.

2. Use the correct dll, Probably you new Windows 7 is a 64-bit version.

Dec 7, 2011 at 12:39 PM

I've installed Winpcap of course. On the same machine if i run the installation of Visual Studio from DVD, after that the app is running.

Dec 10, 2011 at 10:08 AM

Hi so3,


What version of Pcap.Net dlls do you have?



Dec 11, 2011 at 10:08 PM

Hi Boaz,

I have version 0.80, but i've found the problem. I had to install version x86 of Visual C++ 2010 Runtime even if the computer OS was Windows 7 ultimate on 64 bit. Can you explain me why is need the x86 and not the x64 version?


Dec 14, 2011 at 7:57 PM

No, I actually can't.

If you the Windows is indeed 64 bit, and you use the 64 bit Pcap.Net dlls and installed WinPcap 64 bit then I don't see a reason why would you need the x86 version of Visual C++ 2010 Runtime.

Jul 26, 2012 at 4:29 PM

I just had the same issue on Windows Server 2008 R2, which only come in 64 bit.

I'm using the latest version of PCAP Dot Net from the site (


Installing x86 Visual C++ 2010 Runtime fixed it.


I'm using Sharp Develop 4.2 and the machine is a Small instance running on AWS EC2.

Jul 26, 2012 at 8:51 PM

Hi StephenMcGowan,


I'm not sure why this happens.

Did you use the x64 version of PcapDotNet.Core?

Do you use VS on that machine? Do you try to run the application from VS? It might be related to the fact that you use VS that runs on x86 platform.


I've updated the instructions so people would find this solution easier.