PcapDotNet.Core.dll x86

Jan 26, 2012 at 1:37 PM
Edited Jan 26, 2012 at 1:41 PM


I have downloaded PcapDotNet.DevelopersPack.0.8.0 and made some tests on my Windows7 x64 Notebook. I created a small sniffing application for a special protocol and it worked fine on the x64 maschine

Our company is using a lot of 32bit HW running Windows XP SP3, therfore I wanted to create the same application as x86 version.
I replaced the x64 PCAP* assemblies by the x86 PCAP* assemblies, but the application didn't run.

I made a step back and tried to compile the sample solutions from the  PcapDotNet.DevelopersPack.0.8.0 using the x86 branch, but the result was alltimes the same. I could buid the application successfully, but it stopped after start with an exception "one of "PcapDotNet.Core.dll" imported procedure could not be loaded.

I tried to examine the PCAPDOTNET.CORE.DLL with the dependancywalker and got the following messages

Error: At least one module has an unresolved import due to a missing export function in an implicitly dependent module.
Warning: At least one delay-load dependency module was not found.
Warning: At least one module has an unresolved import due to a missing export function in a delay-load dependent module.

The warning "At least one delay-load dependency module was not found" may be caused by the IESHIMS.DLL  but I have got the same warning inspecting the PCAPDOTNET.CORE.DLL for x64.

Have anybody an idea, what I've done wrong

regards Michael 

Jan 27, 2012 at 9:16 AM

Hi Michael,


Can you see what unresolved import does the second warning you get in dependency walker refer to?



Jan 27, 2012 at 10:49 AM

Hi Boaz

I inspected once more the log of the dependency walker and there I found, that the problem was caused by the winpcap.dll.

I checked the version of the winpcap.dll, it was 4.0.2,   too old.
Now I've reinstalled winpcap.dll 4.1.2 and my application works fine on the Windows XP Laptop too..

Thanks for your answer, which encouraged me to analyze more accurate the problem


Jan 27, 2012 at 10:53 AM

No problem.

I'm happy it resolved.